Pb d'Execution Automatique sous Vista !

Tout ce qui concerne l'informatique en général : hardware, pilotes, logiciels...
Bien sûr ici on ne parle pas de gravure !

Pb d'Execution Automatique sous Vista !

Messagepar Pierre G » 21 Jan 2008 22:13

Bonsoir,
Voilà mon problème du soir !
Sur mon ordinateur équipé de Vista j'ai:
- un graveur DVD avec la lettre F
- Un lecteur DVD avec la lettre G
- Un lecteur Virtuel avec la lettre H (DaemonTool 4.12 pour ne pas le nommer)

Jusqu'à hier l'exécution automatique fonctionait sur les 3 lecteurs.
Mais depuis hier soir:

Sur les 2 premiers lecteurs l'execution automatique fonctionne.

Sur le lecteur virtuel ça ne marche pas :twisted: :twisted:
Je précise que les paramètres dans le lecteur sont OK pour l'execution automatique.

Chose bizarre, si je modifie la lettre du lecteur virtuel en autre chose que H, P par exemple et bien ça marche !! :doh: Si je remet H, ça marche plus :twisted: :doh: :doh:

Quelqu'un a une idée ??? :?: :?:

Je suppose que le problème doit se situer dans la clée de registre qui régit la lettre "H" comme lettre de lecteur.
quelqu'un sait où est cette foutue clée ???

Dans l'attente de vos suggestions.

A plus.
Avatar de l’utilisateur
Pierre G
Blue Angel's Doctor
Membre éminent
 
Messages: 1599
Enregistré le: 01 Fév 2003
Localisation: Vaucluse

Messagepar Burnitall » 22 Jan 2008 23:34

Salut,

M'est avis que tu as un conflit logiciel, à tous les coups dans l'un l'exécution automatique est cochée et dans une autre elle est décochée !

Enfin c'est une idée... :wink:
Avatar de l’utilisateur
Burnitall
Enfoiré
Inconditionnel
 
Messages: 3052
Enregistré le: 19 Juil 2004
Localisation: Strasbourg

Messagepar Pierre G » 23 Jan 2008 12:43

Bonjour,
Merci Burnitall, mais ça j'ai déjà vérifié et tout est coché comme il faut.
D'autant qu'avec Vista en fait, tu n'as plus l'execution lecteur par lecteur mais directement par type de contenu dans le panneau de configuration.
Je pense qu'il s'agit d'un problème au niveau du registre puisque si je change la lettre du lecteur ç'est bon .
A plus.
Modifié en dernier par Pierre G le 23 Jan 2008 18:44, modifié 1 fois.
Avatar de l’utilisateur
Pierre G
Blue Angel's Doctor
Membre éminent
 
Messages: 1599
Enregistré le: 01 Fév 2003
Localisation: Vaucluse

Messagepar Colok » 23 Jan 2008 18:17

Salut,

Dans ta base de registre, recherche cette clé: NoDriveTypeAutoRun
HKEY_USERS\S-1-Nombre interminable\Software\Microsof­t\Windows\CurrentVersion\Policies\Explorer
NoDriveTypeAutoRun

Dans le panneau de droite, clique sur NoDriveTypeAutoRun , puis sur modifier et à la place de FF indique 91

Redémarre ton PC
Colok
Membre permanent
Membre permanent
 
Messages: 834
Enregistré le: 23 Déc 2005
Localisation: France

Messagepar Pierre G » 23 Jan 2008 18:50

Bonsoir Colok,

J'ai vérifié la cléf que tu m'a indiqué, la valeur est déjà 91.

D'autres idées ??

A plus.
Avatar de l’utilisateur
Pierre G
Blue Angel's Doctor
Membre éminent
 
Messages: 1599
Enregistré le: 01 Fév 2003
Localisation: Vaucluse

Messagepar garfield67 » 23 Jan 2008 20:54

Dégage Vista... une merde pareil ca devrait pas avoir le droit d'exister...

ps: désolé pour cette intervention peu constructive, j'avais besoin d'exprimer mes conclusions sur ma courte (mais trop longue à mon gout) experience sur cet OS...
athlon xp 2200+; 1Go; xp pro SP 2; NEC-OPTIARC 7173A (ide2 slave); asus dvd e616 [UDMA 100] (ide2 master); maxtor 250go 7200 tpm; asus a7v8x-x (bios 1013); gf fx 5200 128mo

Pas d'aide par MSN ou MP


Image
Avatar de l’utilisateur
garfield67
Matou alsacien
Membre dévoué
 
Messages: 1151
Enregistré le: 06 Mar 2004
Localisation: Alsace

Messagepar Pierre G » 24 Jan 2008 20:46

Salut garfield67,
Je comprends que tu n'aime pas Vista :lol: :lol:
Mais sous XP il y a aussi des soucis avec l'execution automatique.
Regardes ici ce qu'il m'était arrivé en 2006 :doh:

http://forum.gravure-news.com/j-ai-perd ... ht=autorun

A plus.
Avatar de l’utilisateur
Pierre G
Blue Angel's Doctor
Membre éminent
 
Messages: 1599
Enregistré le: 01 Fév 2003
Localisation: Vaucluse

Messagepar Pierre G » 07 Fév 2008 16:19

Bonjour,

Juste un petit up pour voir si quelqu'un a une idée lumineuse !!! :idea: :idea: :?: :?: car ce problème m'énerve !!! :twisted: :twisted: :twisted:

A plus.
Avatar de l’utilisateur
Pierre G
Blue Angel's Doctor
Membre éminent
 
Messages: 1599
Enregistré le: 01 Fév 2003
Localisation: Vaucluse

Messagepar Pierre G » 24 Fév 2008 19:28

Bonsoir,
Je me permets un dernier up, des fois que quelqu'un ait une idée lumineuse !!!! :idea: :idea: :idea:

A plus.
Avatar de l’utilisateur
Pierre G
Blue Angel's Doctor
Membre éminent
 
Messages: 1599
Enregistré le: 01 Fév 2003
Localisation: Vaucluse

Messagepar gowap » 26 Fév 2008 22:02

Tu en as combien des clés NodriveTypeAutorun ?
Sous HKLM ou HKCU ?
S'il y en a plusieurs, c'est celle sous HKLM qui est censée prendre le dessus.
As tu aussi une/des clés NoDriveAutorun (sans "Type").
Si oui, quelles valeurs ?

Ce systeme d'exploitation est pénible...
Je crois que je ne vais pas m'y habituer.
Aucune aide par mail ou Message Privé (n'insistez pas)
Prenez connaissance du règlement (à question illégale, sujet verrouillé),
commencez par faire des Recherches et décrivez clairement vos problèmes.

Lisez les articles et tutoriels
Avatar de l’utilisateur
gowap
Administrateur
Administrateur
 
Messages: 16092
Enregistré le: 01 Aoû 2002

Messagepar Pierre G » 13 Juil 2008 14:14

Bonjour,

Si j'exhume ce post c'est que j'ai fini par trouver la solution à mon problème !!! :clap2: :clap2: :clap2:

Un peu grâce à Gowap :praise: :praise: et à la piste des clés NoDriveAutorun .

C'était elle qui décon***, elle avait une valeur à 91 (hexadécimal) qui doit correspondre, si je ne me trompe pas à 128 (décimal) et qui bloquait la lettre H.
En effet, cette valeur NoDriveAutorun présente dans la clé HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer et ou dans HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer sert à autoriser ou non l'autorun, non pas par type de lecteur (ça c'est la valeur NoDriveTypeAutorun qui le régit) mais par lettre de lecteur.

De base, cette clé n'existe pas sous Vista, mais elle peut-être crée par des logiciels comme DaemonTool.
C'est ce qui a du ce passer pour moi.

Et donc, pour récupérer l'autorun pour toutes les lettres, il faut la mettre la valeur à 0(zéro) ou alors la supprimer carrément.
Sinon, selon sa valeur, elle bloque certaines lettres

Ici, les liens qui m'ont servit:

http://www.bellamyjc.org/fr/windowsnt.html#insertionCD

http://www.pctools.com/guides/registry/detail/156/

http://www.pctools.com/guides/registry/detail/1142/

http://www.microsoft.com/technet/prodte ... x?mfr=true

http://www.microsoft.com/technet/prodte ... x?mfr=true

D'ailleurs, au passage si quelqu'un pouvait m'expliquer de manière simple, voire simpliste, l'histoire des "bit" du site de Bellamy, je lui en serait reconnaissant :praise: :praise:

A plus.
Avatar de l’utilisateur
Pierre G
Blue Angel's Doctor
Membre éminent
 
Messages: 1599
Enregistré le: 01 Fév 2003
Localisation: Vaucluse

Messagepar gowap » 13 Juil 2008 17:14

C'est comme l'illustre JCB. Tu as 26 lettres de lecteurs différentes possibles, et pour chaque lettre de lecteur tu peux activer ou désactiver la notification auto.
L'info est codée en binaire, on affecte un bit à chaque lettre, bit qui prendra donc la valeur 0 ou 1 (1=desactiver pour cette lettre).
Comme il y a 26 lettres, il nous faut 26 bits pour representer toute l'information, et comme 26 n'est pas un multiple de 2, on va stocker l'info sur 32 bits avec les 6 bits "en trop" a 0.
L'ordre des lettres se fait de droite a gauche.
Tu obtiens donc une suite de 32 bits qu'il faut ensuite convertir en décimal ou hexadecimal
Aucune aide par mail ou Message Privé (n'insistez pas)
Prenez connaissance du règlement (à question illégale, sujet verrouillé),
commencez par faire des Recherches et décrivez clairement vos problèmes.

Lisez les articles et tutoriels
Avatar de l’utilisateur
gowap
Administrateur
Administrateur
 
Messages: 16092
Enregistré le: 01 Aoû 2002

Messagepar Pierre G » 13 Juil 2008 20:56

Bonsoir,
gowap a écrit:........comme 26 n'est pas un multiple de 2.......


Ha bon, 26 n'est pas multiple de 2 ???? :doh: :doh:

Sinon, je pense avoir compris, donc si je veux désactiver le lecteur F par exemple, ma valeur va devenir 100000 en binaire soit 32 décimal ou 20 en hexadécimal, c'est ça ??

A plus.
Avatar de l’utilisateur
Pierre G
Blue Angel's Doctor
Membre éminent
 
Messages: 1599
Enregistré le: 01 Fév 2003
Localisation: Vaucluse

Messagepar gowap » 13 Juil 2008 23:17

Pierre G a écrit:Ha bon, 26 n'est pas multiple de 2 ???? :doh: :doh:

Au temps pour moi. Il fallait lire "26 n'est pas une puissance de 2"

si je veux désactiver le lecteur F par exemple, ma valeur va devenir 100000 en binaire soit 32 décimal ou 20 en hexadécimal, c'est ça ??

Oui. Mais comme dit, autant utiliser les outils genre tweak UI et consorts pour bidouiller ce genre de trucs.
Aucune aide par mail ou Message Privé (n'insistez pas)
Prenez connaissance du règlement (à question illégale, sujet verrouillé),
commencez par faire des Recherches et décrivez clairement vos problèmes.

Lisez les articles et tutoriels
Avatar de l’utilisateur
gowap
Administrateur
Administrateur
 
Messages: 16092
Enregistré le: 01 Aoû 2002

Messagepar Pierre G » 14 Juil 2008 20:55

Bonsoir,
Je suis d'accord avec toi, Gowap, qu'il vaut mieux ne pas faire "joujou" avec la base de registre et qu'il vaut mieux utiliser les utiltaires dédiés à ça.

C'était juste pour ma culture générale que je demandais ça, car cette histoire m'a pris la tête pendant un bon moment !!!! :lol: :lol:

A plus.
Avatar de l’utilisateur
Pierre G
Blue Angel's Doctor
Membre éminent
 
Messages: 1599
Enregistré le: 01 Fév 2003
Localisation: Vaucluse

Problème d'exécution automatique windows vista

Messagepar Zincoulou » 19 Nov 2008 9:49

J'ai le même problème que tu as eu Pierre G.

Depuis que j'ai mon nouvel ordinateur HP sous Vista, non seulement l'exécution automatique ne se lance pas malgré que j'ai bien configuré le panneau de Conf, mais en plus lorsque j'essaye d'ouvrir le en passant par l'icône E: du lecteur, le lecteur se comporte comme si le CD, Cd-Rom jeux ou DVD était vierge et m'affiche l'assistant préparation de CD vierge.
Je peux extraire le CD sur le Windows Media player, ou en trouver les données par la recherche windows en recherchant tout dans E:.

Je ne touche pas ma bille en informatique, et si une solution existe à mon problème, j'aimerais bien qu'on m'explique dans le détail comment la mettre en oeuvre.

Merci
Zincoulou
Nouveau Membre
 
Messages: 1
Enregistré le: 19 Nov 2008



  • Publicité

Retourner vers Le coin informatique

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invités

cron