Routeur et FTP [Résolu]

Tout ce qui concerne l'informatique en général : hardware, pilotes, logiciels...
Bien sûr ici on ne parle pas de gravure !

Routeur et FTP [Résolu]

Messagepar ben7900 » 17 Jan 2005 15:00

Bonjour,

Je possède un routeur Olitec Wf400g depuis peu...
Avant j'avais sur mon ordi installé un serveur FTP avec le logiciel Guildftp et denees (pour mettre à jour mon IP (puisque ip dynamique, DDNS)

Mon routeur me permet de créer des serveurs virtuels (http, ftp, smtp, etc) j'ai donc rentré l'ensemble de mes paramètres dans mon routeur mais je n'arrive toujours pas à me connecter sur mon ftp (en utilisant un client ftp, en l'occurence FlashFXP)...Je pense que ça vient des ports entrée/sortie, mais je n'en suis pas sûr...

Guilftp utilise 5000 à 5004
Mais pas de précisions supplémentaires sur les ports entrée et sortie

Pour résumer, j'arrive tjs pas à me connecter sur mon FTP ... :twisted:

J'en suis là...

Si quelqu'un a déjà rencontré ce problème ou connait un logiciel FTP plus simple à utiliser (et plus clair au niveau des ports d'entrée sortie), je veux bien un p'tit coup de main...

D'avance merci

@+
Modifié en dernier par ben7900 le 17 Fév 2005 8:56, modifié 1 fois.
Ben
Avatar de l’utilisateur
ben7900
Membre dynamique
Membre dynamique
 
Messages: 390
Enregistré le: 16 Fév 2004
Localisation: France-Ouest

Messagepar CptDobey » 17 Jan 2005 16:07

Hey,

Le fait est que, c'est ton routeur qui reçoit une adresse sur Internet, ton PC ne reçoit qu'une adresse pour ton lan. Dès lors, ton PC n'est visible que sur ton LAN. Ton routeur est lui visible sur Internet... mais n'a pas de fonctionnalités ftp.

On a parlé ici même il y a un peu plus d'un moi d'un problème identique.

Regarde là :
http://forum.gravure-news.com/viewtopic ... hlight=nat


Ajout: Au temps pour moi, j'avais pas tout lu :wink:

Normalement, le port par défaut du FTP, c'est le port 21. Tu as essayé de te connecter sur ce port ?
Et ton routeur, tu lui as bien dit de faire du forwarding vers l'adresse IP (lan) du PC qui à le serveur FTP ?
Quelle adresse dynamique publies-tu, celle du routeur ou celle du PC ?

Perso, j'utilise WS_FTP_LE c'est gratos pour le particulier.
Perfect maps for perfect frags !
Wanted. Schrödinger's cat. Dead or Alive.
Avatar de l’utilisateur
CptDobey
Baron Samedi
Baron Samedi
 
Messages: 3136
Enregistré le: 26 Jan 2004
Localisation: Bruxelles

Messagepar ben7900 » 17 Jan 2005 17:00

CptDobey a écrit:Normalement, le port par défaut du FTP, c'est le port 21. Tu as essayé de te connecter sur ce port ?
Et ton routeur, tu lui as bien dit de faire du forwarding vers l'adresse IP (lan) du PC qui à le serveur FTP ?
Quelle adresse dynamique publies-tu, celle du routeur ou celle du PC ?


Salut,

Oui, j'ai essayé de paramètrer mon routeur sur port (public) 21 et (privé) 21, le problème c'est que Guildftp (d'après moi) utilise le port 5000 à 5004
et pas le 21, et même quand je lui dde de passer par le 21, ça ne fonctionne pas ("Connection refused")...

Je sais pas si le routeur fait du "forwarding", je sais juste qu'il me dde l'IP de la machine hébergeant le FTP (192.168.0.1 ds mon cas) pour effectuer la conversion je suppose...

Pour l'IP dynamique, je fais la mise à jour par rapport à l'Ip de mon routeur je suppose car j'ai rentré tous mes paramètres DDNS (pr moi dyndns.org) dans mon routeur et celui-ci doit faire la corélation entre les 2, enfin j'espère...ce qui m'énerve c que je ne sais pas si cette maj ddns marche bien...

Je vais voir si ça marche avec ton logiciel

@ suivre :twisted: :twisted:
Ben
Avatar de l’utilisateur
ben7900
Membre dynamique
Membre dynamique
 
Messages: 390
Enregistré le: 16 Fév 2004
Localisation: France-Ouest

Messagepar CptDobey » 18 Jan 2005 10:00

ben7900 a écrit:Oui, j'ai essayé de paramètrer mon routeur sur port (public) 21 et (privé) 21, le problème c'est que Guildftp (d'après moi) utilise le port 5000 à 5004
et pas le 21, et même quand je lui dde de passer par le 21, ça ne fonctionne pas ("Connection refused")...

Je sais pas si le routeur fait du "forwarding", je sais juste qu'il me dde l'IP de la machine hébergeant le FTP (192.168.0.1 ds mon cas) pour effectuer la conversion je suppose...


Tel que je vois les choses (sans l'avoir jamais fait), je dirais que ton routeur attends quelque chose sur le port 21. A toi de le rediriger vers la bonne adresse IP (et le bon port si possible). Si tu ne peux pas forcer le port alors c'est probablement sur le 21 que ça se passe.

Ton routeur a quelle adresse sur ton lan ?
Je demande ça, car bcp de routeur ont par défaut l'adresse 192.168.0.1... Donc ton PC en aurait une autre.

Dans la config du routeur, quand tu indiques vers quelle adresse il faut rediriger les paquet FTP, tu peux forcer le port comme ça : 192.168.0.1:21 ?

Tu as un firewall sur ton PC ?

Pour l'IP dynamique, je fais la mise à jour par rapport à l'Ip de mon routeur je suppose car j'ai rentré tous mes paramètres DDNS (pr moi dyndns.org) dans mon routeur et celui-ci doit faire la corélation entre les 2, enfin j'espère...ce qui m'énerve c que je ne sais pas si cette maj ddns marche bien...


Oui, oui...Note que si tu connais l'ip attribuée à ton routeur, tu peux toujours assayer de le pinguer. Ld DDNS, c'est surtout si tu as une adresse symbolique. Note que c'est le meilleur moyen de connaitre ton adresse si tu n'es pas chez toi.

Je vais voir si ça marche avec ton logiciel
@ suivre :twisted: :twisted:

Un détail : WS_FTP_LE est un client ftp, pas un serveur... :wink:
Perfect maps for perfect frags !
Wanted. Schrödinger's cat. Dead or Alive.
Avatar de l’utilisateur
CptDobey
Baron Samedi
Baron Samedi
 
Messages: 3136
Enregistré le: 26 Jan 2004
Localisation: Bruxelles

Messagepar ben7900 » 18 Jan 2005 14:18

Bonjour,

Effectivement je pense que c'est sur le port 21 que tout passe (et je vais rentrer les paramètres de mon routeur comme ça)

Mon routeur a comme IP 192.168.1.1 (par défaut chez Olitec, ou 192.168.0.250) et mon ordi 192.168.0.1

Oui, j'ai en plus un firewall logiciel (Zone Alarm) mais il laissait passer mon ftp avant l'installation de mon routeur, donc ça doit être ok, au pire, je peux le désinstaller le tps de paramètrer le routeur et le logiciel FTP ...

Pour le ping, je sais que mon routeur est ok, en fait si tu veux, pour paramétrer un routeur, il faut ABS que ton ordi possède une carte réseau (ou usb) et une ip définie (192.168.0.1) autrement tu ne peux pas rentrer ds les paramètres du routeur pour la config, donc pas besoin de le "pinguer"...

Pour le log de FTP, je pensais que c'était un serveur, mais si c'est un client j'en ai déjà un (FlashFXP) et j'en suis content...

Par contre, pour le coté serveur, je crois que je vais abandonner Guilftp et prendre ftp server de typsoft (voir génération NT) qui utilise obligatoirement le port 21, au moins je serai sûr de ça...

Merci pour ton aide, une fois que j'aurais réussi, je ferai une aide sur ce sujet et la mettrais à dispo pour les futurs...

@+ cap'tain
Ben
Avatar de l’utilisateur
ben7900
Membre dynamique
Membre dynamique
 
Messages: 390
Enregistré le: 16 Fév 2004
Localisation: France-Ouest

Messagepar CptDobey » 18 Jan 2005 15:10

A ta place, je virerai temporairement ZoneAlarm (et d'éventuels autres machins du genre), histoire de reduire les sources de stress au maximum. Si tu as le SP2, désactive le firewall de XP aussi... De toute façon avec ton routeur, ZA te sert surtout à voir ce qui sort, pas telement ce qui rentre...n'est-ce pas :wink: ?

Quand je parlais de pinguer le routeur, je voulais dire de l'extérieur, depuis interet. J'imagine bien que sur ton lan tu y arrives :wink:
Perfect maps for perfect frags !
Wanted. Schrödinger's cat. Dead or Alive.
Avatar de l’utilisateur
CptDobey
Baron Samedi
Baron Samedi
 
Messages: 3136
Enregistré le: 26 Jan 2004
Localisation: Bruxelles

Messagepar ben7900 » 16 Fév 2005 9:29

Bonjour,

Je reviens à la charge...ça ne marche toujours pas, je commence à compter les heures de boulot pour ce purée de paramétrage !!

Bon, ben figurez vous que j'ai tout essayé, changer les ports du logiciel ftp, mis en place des serveurs virtuels sur le routeur, ouverture des ports concernant le client ftp et le log ftp (guildftp), mise en place des filtres, tout ce quei est possible et inimaginable (et avec le notice du routeur !!)

Je n'arrive toujours pas à paramétrer ce purée de routeur pour qu'il me laisse passer mon ftp...lorsque je regarde les exemples et les explications, tout semble correct, donc je ne comprends plus !!

Si quelqu'un a un routeur W400 d'Olitec et qu'il est arrivé à bien configuré sa bête, je veux bien un coup de pouce...

Ah si j'oubliais, une question, comment puis je tester pour savoir si l'ip attribuée par mon fai correspond bien au nom dyndns !??? en "pingant" !?

@+



:twisted:
Ben
Avatar de l’utilisateur
ben7900
Membre dynamique
Membre dynamique
 
Messages: 390
Enregistré le: 16 Fév 2004
Localisation: France-Ouest

Messagepar psyko » 16 Fév 2005 10:51

ben7900 a écrit:Ah si j'oubliais, une question, comment puis je tester pour savoir si l'ip attribuée par mon fai correspond bien au nom dyndns !??? en "pingant" !?


Salut :D

Oui, rtu peux faire un ping sur ton @dyndns.org mais sinon, va sur leur site et connecte toi, tu verras les parametres de ton compte :wink:

Sinon, as-tu la possibilité de tester une connexion sur ton ftp depuis l'exterieur (un voisin ...etc) pour être sur que tes pbs ne sont pas dûe à ton LAN ?

Good luck
- Psy - :shock:
Développeur : www.gravure-news.com
Barton @2500+, MSI K7N2 Delta, 2*512 DDR 3200, 1*10+1*20+1*80Go, Leadtek GeForce4 Ti 4200 128Mo MyVIVO, Creative Inspire P580, Freebox... Graveur Pioneer 107D :D ... Debian SID 8)
Avatar de l’utilisateur
psyko
Codeur PHP
Codeur PHP
 
Messages: 1463
Enregistré le: 16 Nov 2002
Localisation: Toulouse

Messagepar ben7900 » 16 Fév 2005 11:12

psyko a écrit:Oui, tu peux faire un ping sur ton @dyndns.org mais sinon, va sur leur site et connecte toi, tu verras les parametres de ton compte :wink:


Bon ok, je viens de voir que tu peux changer les paramètres sur leur site, je vais donc essayer de mettre en direct ma bonne IP, comme ça je saurais direct si ça vient de là ou de mon routeur...

Sinon, as-tu la possibilité de tester une connexion sur ton ftp depuis l'exterieur (un voisin ...etc) pour être sur que tes pbs ne sont pas dûe à ton LAN ?

Good luck


Oui, je bosse avec un pote, spécialisé micro, donc pas de soucis à ce niveau là...

Bon courage pour la suite...
Merci

@+

:D
Ben
Avatar de l’utilisateur
ben7900
Membre dynamique
Membre dynamique
 
Messages: 390
Enregistré le: 16 Fév 2004
Localisation: France-Ouest

Messagepar ben7900 » 17 Fév 2005 9:08

Bonjour à tous,

Bon, ça y est le problème est résolu, le paramétrage était et est ok...
La seule chose c'est que je pensais pouvoir tester Seul mon ftp via un client ftp mais en fait, il n'est pas possible derrière un routeur de tester le FTP ...

Il faut ABSOLUMENT que le test soit fait par une personne extérieure, pas directement du réseau local...Fallait le savoir !!

Pour les prochains, je positionne quelques liens qui m'ont bien dépanné:
(Principalement sur le site GenerationNT)

Se reporter Ici et

Et sur le site du fabricant de votre Routeur bien sûr !

Bon courage et merci à tous...

@+
Ben
Avatar de l’utilisateur
ben7900
Membre dynamique
Membre dynamique
 
Messages: 390
Enregistré le: 16 Fév 2004
Localisation: France-Ouest



  • Publicité

Retourner vers Le coin informatique

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invités